Managing the VDI plugin version

Last Updated:

The VDI plugin auto-update’s default behavior is to install or update the user’s computer to the most recent version of the VDI plugin that is compatible with the VDI Zoom Meeting client. That version will usually be the same as the VDI Zoom Meeting client version but could be a slightly older version if the meeting client has a more recent patch release (which does not include new VDI plugins).

It is possible to also define a specific version of the VDI plugin that should be installed. This option has been provided for administrators with deployment concerns where the version of all software, even a VDI plugin installed on a remote user’s computer, needs to be more controlled.

Prerequisites for managing the VDI plugin version

  • Account owner or admin privileges
  • Your computer or device meets the software requirements for VDI auto-update
  • Zoom desktop client
    • Windows: 5.10.0 or higher
  • VDI plugin
    • Windows: 5.10.0, or compatible auto-update package
  • Organizations using Citrix XenDesktop or VMware Horizon server published desktop, or Windows Remote Desktop
  • Citrix Workspace, VMWare Horizons, AVD client, or Windows remote desktop client
    Note: Citrix Workspace app from Microsoft store is not supported.
  • Virtual Channel policies configured for Citrix

Notes:

  • For the Windows VDI plugin, the VDI plugin auto-update software component .dll is included and is automatically installed with the VDI plugin, starting with version 5.10.0.
  • For the macOS VDI plugin, support for the VDI plugin auto-update for macOS is in development and will be released in the future. The solution will use the same policies added for Windows VDI plugin auto-update.
  • VDI plugins for the Linux platform, including all partner platforms based on Linux, are not currently being developed for the VDI plugin auto-update feature.

How to manage the VDI plugin version

To enforce a specific version of the VDI plugin that should be installed, an additional policy can be added to the virtual desktop. The following provides the format for the registry key required.

Key: SOFTWARE\Policies\Zoom\Zoom Meetings\VDI
Value: AutoUpdatePluginVersion
Value Type: String Value (REG_SZ)
Value Description: Example "5.11.0", plugin release version

Note: Some restrictions and limitations apply when specifying a VDI plugin version.

Zoom Community

Join the 100K+ other members in the Zoom Community! Login with your Zoom account credentials and start collaborating.