Zoom 10DLC campaign registration delay

Last Updated:

Issue

Zoom users are experiencing significant delays in 10DLC campaign registration approval and number pool requests (when adding 49 or more numbers to campaigns).

Cause

We are experiencing delays in the following processes:

  • Campaign approval is taking 2-3 weeks due to a backlog with downstream carriers and providers.
  • Number pool requests may take up to 4 weeks. These should only be requested once your campaign is approved.

Resolution

If you have submitted your brand and campaign and are currently awaiting campaign approval, messaging capabilities will not be impacted.

If you have not yet created a 10DLC brand and campaign, messages might be subject to filtering from downstream mobile operators. If you are receiving errors when sending messages, create a brand and campaign prior to submitting a request to Zoom Support.

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