Join the 70K+ other members in the Zoom Community! Login with your Zoom account credentials and start collaborating.

Join the Community

For questions about the class action settlement, please visit www.ZoomMeetingsClassAction.com

Managing the user experience for incompatible VDI plugins Follow

A frequently asked question is what options are available to detect when a VDI plugin is missing or too old and how to notify the end user that they need to install or update a VDI plugin to a compatible release.    

Zoom provides a number of registry entries to support configuring the minimum version required and what to display when required conditions are not met. 

The following covers four different configuration options. More information is available online for additional VDI client registry settings.

The four options covered in this article are: 

  1. How to show or disable a warning message if the VDI Plugin version does not match the VDI Zoom client version.
  2. What to set for Fallback mode if you want end users to still be able to join meetings when a VDI plugin is missing or incompatible.
  3. If a VDI plugin is either missing or incompatible (too old or greater than the desktop client version) what will be displayed to the end user when they try to join a meeting.
  4. What will be the minimum version of the VDI plugin the VDI Zoom Meeting client will accept for optimizing audio and video for a Zoom meeting.

Warning message for different version of VDI plugin and Zoom meeting client

The Zoom Meeting client checks the VDI Plugin when the user signs into the VDI Zoom Meeting client in their virtual desktop. By default, if the version of the plugin is different than the VDI Zoom Meeting client a pop-up message is displayed recommending the user to install a matching version of the plugin. 

While this dialog is displayed by default, you can add a registry setting to disable displaying this dialog if you want. While the registry string implies the setting enables this dialog, a value of 0 will disable this dialog from being displayed. 

Key: SOFTWARE\Policies\Zoom\Zoom Meetings\VDI 

Value: EnableDifferentVersionTip

Value Type: DWORD

Value Description: This enables or disables an error message display when the VDI client and VDI plugin version do not match. A zero will display no warning message when there is a version mismatch, whereas any other value will display one.

Meeting behavior if a VDI plugin has not been installed

If the end user has not installed a VDI plugin, an administrator can determine if they are allowed to join meetings or if their meeting participation is limited. This behavior is referred to as “FallbackMode” and there are multiple values for the registry settings that determine that behavior.

Key: SOFTWARE\Policies\Zoom\Zoom Meetings\VDI 

Value: FallbackMode

Value Type: DWORD

Value Description:  Each number corresponds to a specific mode:

(1) Normal mode (Behaves like the regular zoom client)

(2) Runs as a screen share meeting (Audio and video are muted by default)

(3) A pop-up appears that will say the user is unable to join the meeting

(4) A dialogue prompt will display an error message. When the user closes the prompt the Zoom app will also be closed. 

(5) Video is disabled.

(6) Video and sharing are disabled.

(7) Video and computer audio are disabled

Comments: If the registry settings are not configured, the default mode is one (1).

Configuring a minimum VDI plugin version required to join a meeting

Administrators can prevent older VDI Plugin releases from being used to join meetings. A registry entry can be configured with a minimum plugin version to check for. If the VDI plugin is less than the minimum version required, the plugin is not used, the connection status is not displayed in the Statistics dialog and the configured FallbackMode value is applied when joining meetings (if no value for FallbackMode is configured, the default mode allows the user to join meetings with all functionality enabled but audio and video will not be offloaded).

Key: SOFTWARE\Policies\Zoom\Zoom Meetings\VDI

Value: MinPluginVersion

Value Type: String Value (REG_SZ)

Value Description: 2.1.5 ~ current

Comments: Configure the version to match your minimum plugin requirement for your deployment.

Configuring a custom dialog message when VDI plugins are missing or incompatible

If any VDI Plugin requirements are not met, a custom dialog can be displayed to the end user. The dialog will be displayed if a VDI Plugin is missing, less than the MinPluginVersion value configured or if the VDI Plugin is greater than the version of the VDI Zoom Meeting client. Please note, as provided in the registry overview below, this dialog is only displayed when the FallbackMode value is configured for 1, 2, 5, 6 or 7.  

Key: SOFTWARE\Policies\Zoom\Zoom Meetings\VDI

Value: FallbackModeTipMsg

Value Type: String Value (REG_SZ)

Value Description: Displays an administrator defined message when the VDI plugin is not usable and fallback mode is set to 1, 2, 5, 6 or 7. When this registry key does not exist or the string value is empty, no dialog message will be displayed.

Comments: The registry table string type does not support a line return. If a user wants a line return, "\n" should be used to indicate a line return. The length of the content string should be no more than 1024 characters, otherwise the vdi client may fail to read the setting.

Screen_Shot_2021-11-03_at_10.43.55_AM.png

The example above will prevent the dialog from being displayed if the version of the VDI plugin and VDI client do not match exactly. The minimum version of the plugin must be equal or greater than 5.7.6. If the VDI plugin does not meet those requirements (or is greater than the client version), a custom message is displayed to the end user. But FallbackMode has been configured to allow the user to still join and fully participate in the meeting even if their audio and video is not optimized.